[Résolu] Affichage du contenu avant header (Créer un compte)

  • WordPress :5.8
  • Statut : résolu
6 sujets de 1 à 6 (sur un total de 6)
  • Auteur
    Messages
  • #2389071
    cartman17
    Participant
    Initié WordPress
    15 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL :
    • Thème utilisé : perso
    • Extensions en place : woocmmerce, acf, yoast
    • Nom de l’hébergeur : ionos
    • Adresse du site :

    Problème(s) rencontré(s) :

    Bonjour, j’ai un soucis d’affichage sur mes pages. J’ai des pages classiques avec un titre et du contenu. Ce contenu apparait 2 fois avant l’appel du “get_header()”, puis la page apparait normalement dessous. Lorsque je commente le get_header ce contenu n’apparait plus mais je ne vois rien dans mon header.php qui pourait expliquer ce soucis. En plus sur mes autres template je n’ai pas ce soucis alors que le header.php est aussi appelé.

    Une idée du probleme ? Merci

    • Ce sujet a été modifié le il y a 4 jours et 5 heures par cartman17.
    #2389073
    Lumiere de Lune
    Participant
    Maître WordPress
    19723 contributions

    Aucune…. comme on ne voit pas, qu’on ne sait pas de quel contenu il s’agit… désolée, je ne développe pas avec une boule de cristal.

    Ta question c’est un peu “docteur, j’ai un truc qui me fait mal dans certains cas. Une idée du problème ?”

    #2389075
    cartman17
    Participant
    Initié WordPress
    15 contributions

    Ah moi qui pensais avoir été clair bon…

    Je résume : je créé une page dans l’admin wordpress avec un titre et du contenu texte tout simple (test page par exemple). L’affichage de cette page se fait via le fichier page.php dont voici le contenu :

    <?php get_header(); ?>
    <div class="content default">
    	<?php while ( have_posts() ) : the_post(); ?>
    	<header class="woocommerce-products-header">
    		<h1 class="woocommerce-products-header__title page-title"><?php echo get_the_title(); ?></h1>
    		<span class="separ"></span>
    	</header>
    	<?php  echo do_shortcode( get_the_content() ); ?>
    	<div class="clear"></div>
    <?php endwhile; ?>
    </div>
    <?php get_footer(); ?>

    le soucis c’est que le contenu saisi (test page par exemple) apparait 2 fois avant le “get_hearder()” puis le code de ma page.php est correctement affiché.

    #2389077
    mathieu42
    Participant
    Maître WordPress
    908 contributions

    la fonction “get_header” ne fait pas que lancer le fichier header.php, elle peut aussi lancer des actions et des filtres.

    essayez déjà un autre thème pour voir si le souci vient peut être d’une extension.

     

    #2389078
    cartman17
    Participant
    Initié WordPress
    15 contributions

    J’ai activé le thème natif “Twenty Nineteen” et le soucis est présent aussi. Va falloir que je désactive les extensions 1 par 1 pour voir laquelle créé ce truc du coup.

    #2389079
    cartman17
    Participant
    Initié WordPress
    15 contributions

    Le soucis vient d’un plugin perso. J’avoue ne pas avoir pensé aux extensions… Merci

6 sujets de 1 à 6 (sur un total de 6)
  • Vous devez être connecté pour répondre à ce sujet.