Activer « image à la une » sur wordpress (Créer un compte)

  • Statut : non résolu
15 sujets de 1 à 15 (sur un total de 27)
  • Auteur
    Messages
  • #555403
    bridilou
    Participant
    Initié WordPress
    11 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : 4.1.1
    – Version de PHP/MySQL :
    – Thème utilisé : Arras
    – Extensions en place :
    – Nom de l’hebergeur : Olympe.in
    – Adresse du site : http://parionsentreamis.fr

    Problème(s) rencontré(s) :

    Bonjour.

    Après une tentative de hacking sur mon site ce weekend et juste résolu par mon hébergeur, je rencontre un petit problème. Aujourd’hui, pour créer un article, je me suis aperçu que je n’avais plus le pavé « image à la une » en bas à droite. Je suis très embêté car j’illustre toujours mes propos par une image.

    J’ai consulté des sites d’aides mais après des essais peu concluants j’aimerai l’avis de personnes plus aptes.
    Comment dois-je procéder concrètement ?

    J’ai essayé de rajouter ce fameux code conseillé dans mon fichier functions.php sous mon dossier dans la racine wordpress et de lancer mon FTP.

    Résultat aucun changement. Alors d’où vient l’erreur ? De la mise à jour de WordPress par mon hébergeur ?

    Je me suis rendu compte que ce code était déjà présent au préalable dans le fichier function.php.
    Merci de me guider sur les bonnes manip’ à effectuer et l’emplacement idéal pour inscrire ce fameux code sauveur..

    Cordialement,
    Bridilou

    #1025312
    Gueblo
    Participant
    Maître WordPress
    1058 contributions

    quand tu veux ecrire ton article tu vas en haut à droite sur « options de l’ecran » et tu t’assures que la case « image à la une » est cochée.
    Dis moi si c’est ok maintenant.

    #1025313
    bridilou
    Participant
    Initié WordPress
    11 contributions

    Non, rien du tout, je n’ai pas l’option « image à la une »..

    #1025314
    Franck (fge)
    Modérateur
    Maître WordPress
    9572 contributions

    Cette option est déjà présente dans WordPress 4.1.1 (une mise à jour serait pas mal soit dit en passant). Soit c’est une version préhistorique où l' »image à la une » n’existait pas encore soit tu n’es pas au bon endroit. Avant d’utiliser les « options de l’écran » suggéré par Gueblo, tu t’es bien positionné sur une page de rédaction d’un article ?

    #1025315
    bridilou
    Participant
    Initié WordPress
    11 contributions

    Bonjour fge,

    Depuis l’installation du plugin « itheme security » conseillé par mon hébergeur suite à la tentative d’hacking sur mon site, je n’ai plus le pavé « image à la une ». Ce dernier m’a même mis à jour la dernière version 4.1.1 que je n’avais pas effectué jusqu’à maintenant..

    Cela fait 2 ans que j’ai mon site et que je rédige des articles au quotidien. Je suis bel et bien au bon endroit. J’ai le pavé sur la droite « Catégorie », « Mots Clés » et en bas, j’ai du vide et je n’ai plus le pavé « Image à la une ».

    J’ai aucune possibilité de case à cocher dans « options de l’écran »..

    #1025316
    Gueblo
    Participant
    Maître WordPress
    1058 contributions

    aucune ? tu n’as absolument rien dans « options de l’ecran » ?

    #1025317
    PhiLyon
    Modérateur
    Maître WordPress
    28260 contributions

    Bonjour.

    Pour info le thème n’est plus mis à jour depuis 3 ans.

    🙂

    #1025318
    Gueblo
    Participant
    Maître WordPress
    1058 contributions

    si il s’agit du thème que l’on trouve ici http://www.arrastheme.com/ et que l’on peut télécharger en cliquant sur download alors effectivement le fichier functions.php prévoit le support des images à la Une.
    Donc soit vous avez une case « image à la une » dans les « options de l’écran » et elle n’est pas cochée
    soit il y a une erreur Php quelque part, qui pourrait être dûe par-exemple à une incompatibilité des versions php actuelles avec la manière dont votre thème est codé.

    #1025319
    PhiLyon
    Modérateur
    Maître WordPress
    28260 contributions

    Sur le site c’est la version 1.5.3-RC1

    Effectivement, après recherche, il y a eu une refonte du thème c’est expliqué là http://arrastheme.net/arras-in-2015/

    🙂

    #1025320
    Gueblo
    Participant
    Maître WordPress
    1058 contributions

    ah oui effectivement…

    bridilou, si tu n’as pas compris ce que dit PhiLyon, je te fais un résumé :
    sur ton site le thème arras est en version 1.5.3-RC1

    or actuellement ce thème, chez le développeur du thème, est en version 3.0.1
    Autant dire que tu as zappé quelques mises à jour apparemment.

    Il faudrait sans doute que tu mettes à jour ton thème.
    Cependant, je te conseille vivement de ne pas faire de mise à jour automatique mais de :
    1/ sauvegarder ton thème actuel, ou au moins le renommer afin d’être certain qu’il ne soit pas écraser par le nouveau (au cas où il sera bon de pouvoir le retrouver et le remettre en place)
    Pour bien faire, fas egalement une sauvegarde de ta bdd

    2/installer le nouveau thème

    3/ l’activer

    #1025321
    Gueblo
    Participant
    Maître WordPress
    1058 contributions

    et pour info, tu as raté 8 ou 9 mises à jour de ton thème
    tu peux les trouver toutes ici : https://github.com/iCaspar/arras/releases

    #1025322
    bridilou
    Participant
    Initié WordPress
    11 contributions

    Merci pour toutes ces réponses rapides et précieuses.

    Si j’ai bien compris, je télécharges la dernière version de Arras (le lien web de Gueblo dans son dernier message), je retournes sur mon site wordpress, je vais dans Thèmes -> « ajouter des thèmes » je vais rechercher Arras dans mes documents et j’active le tout ?

    Effectivement, j’ai du rater plusieurs mises à jour..

    #1025323
    Gueblo
    Participant
    Maître WordPress
    1058 contributions

    pas sûr que tu aies bien compris
    faut sauvegarder ton theme et ta base avant !
    et la dernière version tu la trouve sur le lien de PhiLyon

    #1025324
    bridilou
    Participant
    Initié WordPress
    11 contributions

    J’ai sauvegardé mon ancien thème, téléchargé le nouveau de Arras et activé ce dernier sur mon site.

    Aucun changement, le pavé « image à la une » n’est toujours pas présent.

    J’ai questionné mon hébergeur et ce dernier se demande si ce n’est pas le plugin « Itheme security » qui bloque cet accès.. Qu’en pensez-vous ?

    Désolé de vous déranger pour ce petit truc anodin..

    #1025325
    Gueblo
    Participant
    Maître WordPress
    1058 contributions

    désactive-le et tu auras vite ta réponse 🙂

15 sujets de 1 à 15 (sur un total de 27)
  • Vous devez être connecté pour répondre à ce sujet.