Activation d’un thème: Vous devez avoir des droits supérieur (Créer un compte)

  • WordPress :5.5
  • Statut : non résolu
7 sujets de 1 à 7 (sur un total de 7)
  • Auteur
    Messages
  • #2369667
    oderobert
    Participant
    Initié WordPress
    23 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : 8.0
    • Version de WooCommerce : 5.0.0
    • Thème utilisé : T’ai le meewenty Nineteen
    •  Extensions en place :Classic Editor  Contact Form 7  Hello Dolly  Insert Special Characters My Custom Functions Payfacile Simple Custom CSS and JS Yoast SEO
    • Nom de l’hébergeur : localhost
    • Adresse du site : localhost/wordpress

    Problème(s) rencontré(s) :

    Bonjour,

    Dans WordPress, j’ai le message ci-dessous quand j’essaie de personaliser le thème Twenty Nineteen ou d’activer un auttre thème

    De plus j’ai tout le temps un popup de connexion à l’administration du site

    J’ai modifié le fichier wp_user et wp_metauser dans la base de donnée selon les indications fournies sur internet, créé un nouveau compte en tant qu’administrateur

    Je pense quil faut accéder à des droits de modification, suppression dans un menu quelque part mais je ne le trouve pas

    Merci pour votre aide

    Cordialement

    Message qui s’affche :
    <h1>Vous devez avoir des droits supérieurs.</h1>
    Désolé, vous n’avez pas l’autorisation de personnaliser ce site.

     

    • Ce sujet a été modifié le il y a 2 semaines et 2 jours par oderobert.
    #2369672
    mathieu42
    Participant
    Chevalier WordPress
    427 contributions

    vous avez eu le souci après avoir modifié la base de données ?

    ou alors vous avez modifié la base de données pour essayer de corriger le souci de droit d’accès ?

    #2369676
    oderobert
    Participant
    Initié WordPress
    23 contributions

    Bonjour

    En fait, comme il y avait beaucoup de plantages (extension SumoMe, ajouter du code html, ..) sur wordpress version 5.6.1  je suis revenu à une version antérieure 5.0 et malheurement les problèmes n’aviaent pas disparu

    Donc, je suis revenu à nouveau à la version 5.6.1 et j’ai eu des problèmes avec l’accés à l’admin de mon site sur localhost

    J’ai changé le champ  user_pass du fichier wp-users, créé un nouvel utilisateur admin dans wp_user et changé le champ wp_capabilities du fichier wp_usermeta à  “a:1:{s:13:”administrator”;b:1;}” comme il est mentionné dans plusieurs sites

    Mais les problèmes persisitent

    Merci par avance pour votre aide

    Cordialement

    #2369683
    oderobert
    Participant
    Initié WordPress
    23 contributions

    Bonjour

    J’ai repéré le code qui pose problème dans themes.php du dossier wp-admin

    if ( ! current_user_can( ‘switch_themes’ ) && ! current_user_can( ‘edit_theme_options’ ) ) {
    wp_die(
    ‘<h1>’ . __( ‘You need a higher level of permission.’ ) . ‘</h1>’ .
    ‘<p>’ . __( ‘Sorry, you are not allowed to edit theme options on this site.’ ) . ‘</p>’,
    403
    );
    }

    Ce code doit correspondre à du paramétrage quelque part et je ne le trouve pas

    Merci par avance pour votre aide

    Cordialement

    #2369684
    mathieu42
    Participant
    Chevalier WordPress
    427 contributions

    comme nous vous l’avions dit dans l’autre discussion, plusieurs soucis viennent de PHP 8 qui n’est pas encore bien géré par toutes les extensions.

    de plus en utilisant des anciens fichiers de wordpress, vous avez peut-être bloqué quelque chose dans les valeurs de la base de données.

    donc je vous conseille de recommencer avec un serveur qui utilise PHP 7, vous allez surement remettre le site en place plus rapidement qu’en essayant de corriger vos soucis actuels.

    #2370205
    oderobert
    Participant
    Initié WordPress
    23 contributions

    Bonjour

    Merci pour votre réponse

    Sachant que je souhaite faire du développement Web et créer 2 ou 3 sites pour mon activité, que me recommanderiez-vous comme serveur d’hébergement ou y-a-t-il un comparatif fiable ?

    Merci par avance

    Cordialement

    #2370314
    Flobogo
    Modérateur
    Maître WordPress
    16924 contributions

    Bonjour,

    Il est tout à fait inutile de recréer un administrateur alors que vous êtes sur un serveur local.
    Et on ne repasse pas “d’un claquement de doigts” de WP 5.6 à WP 5.0 puis inversement.
    Le code que vous avez “repéré” dans wp-admin correspond effectivement au message que vous avez, mais il ne faut surtout pas toucher aux dossiers wp-admin ou wp-includes qui servent à faire fonctionner WordPress.

    Bref, vous intervenez sur votre site en faisant des modifications dont vous ne comprenez pas le sens. Comme vous êtes en installation locale (pour tester), le plus simple serait de repartir de zéro, si vous n’avez pas de sauvegarde de la base de données.

    J’ai lu sur un autre topic que vous êtes en PHP 8 à cause de XAMP. Le plus simple serait d’installer WAMP (pour Windows ou Mac) ou Local by Flyweel (quelque soit l’OS), où vous pouvez modifier la version PHP.

     

7 sujets de 1 à 7 (sur un total de 7)
  • Vous devez être connecté pour répondre à ce sujet.