Accès Site d’un sous domaine depuis URL

  • WordPress :4.9.9
  • Statut : non résolu
4 sujets de 1 à 4 (sur un total de 4)
  • Auteur
    Messages
  • #2219251
    H0ru5
    Participant
    Initié WordPress
    2 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : 7.0.30
    • Thème utilisé : Mesmerize
    • Extensions en place : Classic Editor, Contact Form7, Mesmerize Companion, PDF Embbeder, Realy Simple SSL, WPForms Lite, One Click Demo Import
    • Nom de l’hébergeur : Hébergé chez moi (Debian 9, mariaDB, Apache2, PHP7)
    • Domaine : thibautf.fr (Principal) acheté chez 1and1, osiris.thibautf.fr (Sous-Domaine)
    • Adresse du site : thibautf.fr

    Problème(s) rencontré(s) :

     

    Bonjour à tous !

    Je suis nouveau sur le serveur, de ce fait j’espère que le sujet à sa place ici.

    Que je vous explique…

    Chez moi j’ai un vieux dell qui tourne sur lequel j’ai installé debian9 avec un serveur LAMP (Apache, MySQL, PHP) ainsi que de wordpress. J’ai également acheté, il y a peu, un nom de domaine chez 1and1: thibautf.fr

    Tout va bien jusque là, j’utilise mon site wordpress avec le domaine thibautf.fr et tout va bien. Aujourd’hui je me suis dit pourquoi pas faire un sous-domaine sur lequel je ferais un autre site (Toujours en lien avec le premier mais ne propose pas les meme chose dessus).

    J’avais donc:

    thibautf.fr —-> Site principal sur domaine qui sert de portfolio, portefeuille de compétences, blog, tutos etc…

    et j’aurais voulu que

    osiris.thibautf.fr —-> Devienne un site secondaire sur un sous-domaine qui me servirait de site plus commercial (Services, biens etc)..

     

    Sur le site de 1and1 j’ai bien créé le sous domaine, j’ai bien modifié la zone DNS de manière à ce que le domaine pointe vers mon IP.

    J’ai ensuite vu qu’il fallait modifier wp-config pour rajouter la ligne: define(‘WP_ALLOW_MULTISITE’, true);

    Ce que j’ai fait, je me connecte sur le pannel WP et pas de problème je vois bien la possibilité de créer un deuxième site.

    Je le créé, je met osiris.thibautf.fr, je valide il me confirme la création de mon site..

    Maintenant, si je clique sur Mes Site -> Osiris

    J’arrive effectivement sur le cpanel du site Osiris, je peux aller sur le site qui donc possède le thème par défaut, etc… Tout est NORMAL !

    MAIS ! (Oui sinon c’est pas drôle..)

    Si par exemple je tape directement l’URL osiris.thibautf.fr alors là il me redirige vers thibautf.fr…. et donc sur la page de mon site normal fonctionnel…

    Là ou je ne comprend pas, c’est que dans ma zone DNS de mon domaine (et sous domaine) j’ai associé thibautf.fr et osiris.thibautf.fr sur la même ip public (Mon serveur WP/LAMP).. Mais comment le serveur sait que pour une requete sur le domaine thibautf.fr wordpress affiche le site ThibautF et pour une requete sur le sous-domaine osiris.thibautf.fr wordpress affiche le site Osiris..

    Pour moi ca vient de mon .htaccess…. il ressemble à ça actuellement:

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^wp-admin$ wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]

     

    J’ai besoin d’aide… et surtout surtout surtout d’une explication claire de comment marche htaccess, comment sont gérés les sites etc…

     

    Derniere chose qui peut peut-être aider, je n’arrive pas non plus à mettre des permalinks personnalisés, même simplement autre que celui par défaut… Dès que je change, il me sort une erreur 404.. j’ai déjà essayé de l’effacer de le remettre, de changer les droits RW de htaccess (je l’ai passé en 644 en attendant)… Donc pour l’instant je m’en sors avec des liens pourris… ^^

     

    Voilà ! Si jamais il y a besoin de quelques infos sur ma machine, ce que je sais ou ce que j’ai fais auparavant, je suis dispo !!

     

    Merci beaucoup d’avance,

     

    H0ru5 – Thibaut

    • Ce sujet a été modifié le il y a 1 month et 2 weeks par  H0ru5.
    #2219709
    yrdna
    Participant
    Chevalier WordPress
    244 contributions

    J’ai eu ce souci lors de l’installation d’un sous-domaine sur un multisite, si mes souvenirs sont bon ça ne viens pas du htaccess, il faut autoriser WP à gérer la création de sous-domaine et pour ça depuis ton Cpanel il faut créer un sous-domaine de ce type *.thibautf.fr

    Voir le tutoriel en anglais suivant–> https://www.wpbeginner.com/wp-tutorials/how-to-install-and-setup-wordpress-multisite-network/ à la section Setting Up Wildcard Subdomains

    Si besoin à la fin de la manip rafraîchir les permaliens

    #2219710
    yrdna
    Participant
    Chevalier WordPress
    244 contributions
    #2219786
    H0ru5
    Participant
    Initié WordPress
    2 contributions

    Merci beaucoup de ta réponse Yrdna. Je vais essayer ça.

    En attendant pour ceux ayant un problème similaire, je vous transfère la réponse de mon maitre d’apprentissage, il explique bien en détails.

     

    Salut Thibaut,

     

    1. Tuto de référence : https://www.howtoforge.com/tutorial/install-wordpress-on-lamp-in-debian-9/

     

    1. Je viens de tester et cela m’a l’air de fonctionner. Mais y-a-t-il un raison particulière pour partager la même installation WordPress ?

    En général, on ne fait jamais cela, car si tu as un problème sur ton installation WordPress, tu perds tout. De plus quid des plugins.

    Tu peux isoler les deux en ajoutant une deuxième installation WordPress dédié à Osiris.

    Cela évitera aussi les effets de bords.

    Au mois, si lors d’une mise à jour, cela corrompt ton installation, le deuxième site continuera de fonctionner. De plus SIMPLE is THE BEST.

    Par contre, je suis d’accord, cela te fait deux installations à maintenir… Cependant, avec les outils de WordPress, la maintenance est devenue plus facile.

    Personnellement, dans ce genre de cas, j’aurais fait la chose suivante :

    • Domaine thibault.fr => Record A sur 2.x.5x.x0 (Ip Publique)
      • Sous domaine : www => Record CNAME sur thibault.fr
      • Sous domaine : osiris => Record CNAME sur thibault.fr

    Comme cela, je n’ai besoin de changer l’IP qu’à un seul endroit en cas de besoin.

    • Sur mon serveur LAMP :
      • Ajout du module URL REWRITING d’APACHE
      • Création de l’emplacement des fichiers dans /var/www/html :
        • /var/www/html/site1 pour le site par défaut
        • /var/www/html/site2 pour Osiris

    => Upload des fichiers de wordpress

    • Création des bases de données site1 et site2 dans mysql
      • Création de la base de données 1
      • Nom de la base Site1
      • Nom de l’utilisateur Site1
      • Mot de passe : mdp spécifique
      • Préfixe : WP_ (au cas ou)

    PS : ton mysql ne doit pas autoriser les connexions autre qu’en local pour des raisons de sécu.

    Au prompt linux en root : mysql_secure_installation

    • Lire : https://httpd.apache.org/docs/2.4/vhosts/name-based.html
    • Création du Named Virtual Host par défaut (celui qui commence par 00-) en http et en https.
    • Création du second Named Virtual Host (01- ou 10-, on s’en fou, c’est pour que tu t’y retrouves) en http et https
      • Servername : osiris.thibault.fr
      • Pas de ServerAlias
    • Custom des logs dans /var/log/apache2 avec les noms des fichiers logs qui commencent par site1-NomDuLogStandardDApache.log etc. et mise à jour des fichiers de namedVirtualHost (ceux qui commencent par 00- ou 10- ou 01-)
    • Enable des Virtuals Hosts : a2ensite 00-NomDuNVH puis a2ensite 10-NomDuNVH
    • Redémarrage du service apache (et pas avant, sinon plantage apache)
    • Lancement des installations de WordPress et tweak url rewriting

    PS : ne pas oublier SUDO si tu n’es pas root

     

    1. <u>Pour permaliens :</u>
      1. WP et url rewriting :
        1. https://www.hongkiat.com/blog/wordpress-url-rewrite/
        2. https://apache.developpez.com/cours/urlrewriting/
      2. Permaliens WordPress : https://codex.wordpress.org/fr:Utilisation_des_permaliens

    Je pense qu’il te manque le module URL-REWRITE d’APACHE

    Pour l’activer « a2enmod rewrite »

    Je ne touche pas aux fichiers livrés par WordPress. Après tu dois pouvoir trouver des ressources sur le net.

    Le .htaccess permet de définir des fonctionnements d’apache particulier pour un site web particulier.

    Ce sont des éléments de fonctionnement locaux.

    Pour WordPress, il est plus que nécessaire. C’est lui qui permet de définir le fonctionnement des permaliens.

    Si tu veux le supprimer, il faut désactiver les permaliens en activant le mode « PLAIN ».

     

    Bon courage

     

    J’espère que ça aura pu aider.

     

    Cordialement Thibaut

4 sujets de 1 à 4 (sur un total de 4)
  • Vous devez être connecté pour répondre à ce sujet.