[Résolu] Accès impossible aux rubriques de gestion du site (Créer un compte)

  • WordPress :5.8
  • Statut : résolu
15 sujets de 1 à 15 (sur un total de 28)
  • Auteur
    Messages
  • #2423047
    toff67
    Participant
    Initié WordPress
    13 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : 7.4
    • Thème utilisé : Catch box
    • Extensions en place : countdown and clock, nextgen gallery, location weather, table press, all-in one migration, gwolle guestbook
    • Nom de l’hébergeur : OVH
    • Adresse du site : https://fouteux.fr/

    Problème(s) rencontré(s) :

    Je peux me connecter à wordpress en saisissant utilisateur et mdp.

    Mais la plupart des rubriques indispensables pour gérer mon site sont inaccessibles (articles, médias, pages, commentaires, réglages, etc…) : lorsque je clique sur celles-ci, j’ai le message « Forbidden You don’t have permission to access this resource. »

    OVH me dit de changer de mot de passe via leur module, mais lorsque je le fais, je reçois un mail de leur support qui me dit « qu’une erreur est survenue lors du changement du mot de passe administrateur pour le module WordPress sur l’hébergement lié au nom de domaine fouteux.fr ». La connexion à la base de données est impossible.

    Autre point bizarre : si je demande de changer le mot de passe directement via wordpress (sur la page d’accueil de saisie de l’identifiant, « mot de passe oublié ? »), je ne reçois aucun mail !

    Je ne sais vraiment pas quoi faire…

    Merci pour vos retours.

    #2423133
    Flobogo
    Modérateur
    Maître WordPress
    20120 contributions

    Bonjour,

    Savez-vous utiliser un logiciel FTP comme Filezilla ? Savez-vous accéder à votre base de données dans PhpMyAdmin ?

    #2423141
    toff67
    Participant
    Initié WordPress
    13 contributions

    Oui, j’ai accès à ma base via phpmyadmin et je sais utiliser Filezilla ou équivalent.

    #2423164
    Flobogo
    Modérateur
    Maître WordPress
    20120 contributions

    Parfait (quelle idée d’être passé par le module OVH, si vous savez utiliser les « bons » outils).

    Dans PhpMyAdmin, faites une sauvegarde de votre BDD et vérifiez dans la table wp_users (chez vous, le préfixe est différent de wp_ je crois que c’est modxxx_) si vous êtes bien administrateur. Vérifiez qu’il n’y a pas d’utilisateur inconnu, surtout avec le statut administrateur.

    Si le problème ne vient pas de là (vous ne voyez rien de suspect dans la table wp_users), alors on passe au FTP
    Là aussi, avant toute chose, faites une sauvegarde : du dossier wp-content / du fichier wp-config.php / du fichier .htaccess à la racine du site (au même niveau que wp-config.php)

    Ensuite, suivez ce tuto pour dépanner l’erreur 503.

    #2423277
    toff67
    Participant
    Initié WordPress
    13 contributions

    Bonjour,

    Le point numéro 2 du tuto m’a permis de régler le problème : suppression du fichier .htaccess.

    Merci beaucoup pour votre réactivité et votre efficacité.

    #2423343
    Flobogo
    Modérateur
    Maître WordPress
    20120 contributions

    suppression du fichier .htaccess

    Attention, il faut le « régénérer » si vous voulez utiliser les permaliens (URL avec le nom de l’article, ou lieu de ?=123 par exemple). Dans le menu « admin », allez à l’onglet permaliens, choisissez la structure voulue (ou ne changez rien si c’est déjà OK), puis sauvegardez en bas de page, même si vous n’avez rien changé → c’est ce qui permet de re-créer automatiquement le fichier .htaccess

    #2423381
    toff67
    Participant
    Initié WordPress
    13 contributions

    En effet, merci, j’avais bien fait cette manipulation dans la foulée de la suppression du fichier !

    #2424394
    toff67
    Participant
    Initié WordPress
    13 contributions

    Bonjour,

    J’ai essayé de me connecter à mon site ce jour et mon mot de passe ne fonctionnait plus. Je l’ai donc changé en passant par phpmyadmin. En me connectant, j’ai de nouveau le message « Forbidden – You don’t have permission to access this resource. »

    J’ai essayé de supprimer le fichier .htaccess puisque c’est cela qui avait résolu mon problème, mais rien n’y fait, j’ai toujours le même message…

    Auriez-vous une solution ?

    Merci !

    #2424429
    Flobogo
    Modérateur
    Maître WordPress
    20120 contributions

    Il y a peut-être un piratage.

    Aviez-vous suivi ces indications de mon post du 03 octobre ?

    Dans PhpMyAdmin, faites une sauvegarde de votre BDD et vérifiez dans la table wp_users (chez vous, le préfixe est différent de wp_ je crois que c’est modxxx_) si vous êtes bien administrateur. Vérifiez qu’il n’y a pas d’utilisateur inconnu, surtout avec le statut administrateur.

    #2424485
    toff67
    Participant
    Initié WordPress
    13 contributions

    Oui, il n’y a rien de particulier.

    Je ne peux même plus accéder au site, j’ai le même message que pour accéder à wordpress : « Forbidden – You don’t have permission to access this resource »

    J’ai signalé à OVH.

    Hier soir, j’ai fait l’étape 4 du auto pour désactiver les extensions en renommant avec « -disabled », via FTP. Cela n’a rien changé mais en remettant le nom initial (« plugins »),  je vois maintenant que mes répertoires ont un points d’interrogation rouge.

    Bref, la situation est compliquée, j’ai l’impression qu’OVH a tout bloqué, mais je ne vois rien de particulier dans mon interface d’administration…

    #2424500
    ferman
    Participant
    Maître WordPress
    6996 contributions

    Bonjour,

    A quoi ressemble votre fichier .htaccess maintenant. Faites-en une copie et mettez-la en pièce jointe en cachant tout ce qui pourrait être confidentiel. Sans doute rien mais vérifiez quand même.

    Renommez (encore

    Pouvez-vous par FTP vérifier les permissions des fichiers et dossiers et les ajuster si nécessaire comme précisé ICI

    Pour le point d’interrogation rouge, je n’ai jamais entendu parler de ça, ils doivent en connaître la signification chez OVH. Demandez sur le forum (pas le support) OVH.

    Vous avez des tas de référence (des images) à « http : // bloomsdayrun.org ». C’est normal?

    • Cette réponse a été modifiée le il y a 1 année et 7 mois par ferman.
    #2424513
    toff67
    Participant
    Initié WordPress
    13 contributions

    .htaccess ressemble à ceci :

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    DirectoryIndex index.php
    RewriteRule ^index.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    Mon site est de nouveau accessible (suite à recopie d’une sauvegarde de htaccess via ftp), mais pas mon tableau de bord et autres rubriques (toujours « Forbidden You don’t have permission to access this resource.)

    J’ai vérifier les permission, puis supprimé htaccess, rien n’y fait.

    Faire la manipulation pour enlever les plugins (renommer en disabled via ftp), ne change rien non plus…

    Je me retrouve donc dans la situation du 3 octobre (message initial) !

     

     

    #2424529
    ferman
    Participant
    Maître WordPress
    6996 contributions

    Il me semble que vous n’avez pas testé ça. Essayez de vous connecter avec l’adresse en pièce jointe.

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2424542
    toff67
    Participant
    Initié WordPress
    13 contributions

    C’est avec cette adresse que je me connecte toujours à mon espace wordpress, mais actuellement, j’ai le message « Forbidden You don’t have permission to access this resource »

    • Cette réponse a été modifiée le il y a 1 année et 7 mois par toff67.
    #2424547
    ferman
    Participant
    Maître WordPress
    6996 contributions

    Pouvez-vous mettre en pj une copie du fichier index.php et de wp-config. Seulement celles qui sont entre la balise < ? php ouvrante et  /** Nom de la base de données de WordPress. */, et celles qui sont après /* C’est tout, ne touchez pas à ce qui suit ! Bon blogging ! */. Ne mettez rien de confidentiel.

    Votre ht access n’a pas bougé?

15 sujets de 1 à 15 (sur un total de 28)
  • Vous devez être connecté pour répondre à ce sujet.