[Résolu] Accès impossible à mon site (Créer un compte)

  • WordPress :5.1
  • Statut : résolu
15 sujets de 16 à 30 (sur un total de 35)
  • Auteur
    Messages
  • #2415111
    confrerie71
    Participant
    Initié WordPress
    21 contributions

    Ci joint capture écran /wp-content/themes

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2415113
    pasglop
    Participant
    Maître WordPress
    699 contributions

    Bien vu, pas regardé la capture. Je m’en vais me flageller !

    #2415114
    confrerie71
    Participant
    Initié WordPress
    21 contributions

    @Li-An : quels sont les fichiers à récupérer et où les récupérer ?

    #2415115
    confrerie71
    Participant
    Initié WordPress
    21 contributions

    @ pasglop : pas besoin de flagellation et merci de m’aider

    #2415127
    Li-An
    Participant
    Maître WordPress
    28545 contributions

    Si vous aviez la dernière version, les fichiers sont là https://wpfr.net/

    #2415305
    m.m.lugara@gmail.com
    Participant
    Initié WordPress
    1 contributions

    Bonjour,

    lorsque j’essaie de me connecter sur mon site wordpress ( wordpress.com/log-in) , il ne reconnait plus mon identifiant.

    Comment puis-je me connecter à nouveau sur mon site?

    Merci infiniment,

    Marine

    #2415429
    Flobogo
    Modérateur
    Maître WordPress
    20193 contributions

    Bonjour @m-m-lugaragmail-com

    ici, vous êtes sur le forum des sites auto-hébergés, pas chez wp.com. Le forum qui vous concerne est .

    #2415435
    Flobogo
    Modérateur
    Maître WordPress
    20193 contributions

    @confrerie71 :

    Pour augmenter la version PHP, voici les infos généralement données @ferman, utilisateur qui connaît bien le fonctionnement de votre hébergeur :

    Vous devez d’abord  accéder au tableau de bord OVH. Une fois là, vous allez dans votre hébergement, et vous verrez ce qui est en pièce jointe (partie droite) vous voyez votre version PHP.  Vous cliquez et vous voyez une liste déroulante; choisissez 7.3 puis enregistrez. Après quelques minutes, votre version PHP aura été modifiée (vérifier sur partie gauche de la pièce jointe) .

    Par la suite, vous referez la procédure pour passer en 7.4 (en choisissant au préalable « stable 64 »), mais quand vous serez passé en version supérieur de WP.

    Il faudra ensuite aller voir dans la base de données (PhpMyAdmin) si il y a bien un thème actif, dans la table wp_options (vous pouvez avoir un autre préfixe que wp_)

    • Cette réponse a été modifiée le il y a 1 année et 10 mois par Flobogo. Raison: ajout de la pièce jointe
    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2416133
    confrerie71
    Participant
    Initié WordPress
    21 contributions

    Encore merci de votre aide.

    Mais dans le tableau de bord OVH, je ne trouve nulle part mention de la version PHP et je n’ai pas de pièce jointe !

     

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2416138
    HimSelf
    Participant
    Chevalier WordPress
    141 contributions

    Une fois que tu as renomé le fichier plugin, rend toi sur l’adresse du tableau de bord ( /wp-admin/ ) c’est a ce moment la et seulement a ce moment la que les plugins se désactiveront quand tu chargeras la page.

    #2416171
    confrerie71
    Participant
    Initié WordPress
    21 contributions

    Merci @HimSelf, mais après avoir chargé la page /wp/admin/, toujours le même message d’erreur quand j’essaye d’accéder au site  :

    Erreur d’analyse : erreur de syntaxe, T_STRING inattendu dans /home/confreriy/www/wp-includes/load.php à la ligne 1242

     

    #2416191
    ferman
    Participant
    Maître WordPress
    7052 contributions

    Bonjour,

    La version PHP obsolète est sans doute la cause du problème. Vous n’avez pas forcément de fenêtre vous permettant de modifier votre version PHP mais vous avez (ou pouvez créer) un fichier OVH-config. Regardez cet article pour des détails. Passez déjà en 7.2, faites les mises à jour (plugins, thèmes, wordpress) si nécessaire, puis passez en 7.4, toujours selon le même article.

    #2416436
    confrerie71
    Participant
    Initié WordPress
    21 contributions

    Un grand merci @Ferman.

    On avance ;o)

    J’ai créé le fichier .ovhconfig en indiquant la 7.2 mais maintenant j’ai le message :
    Erreur lors de la connexion à la base de données quand j’essaie d’ouvrir le site.

    • Cette réponse a été modifiée le il y a 1 année et 10 mois par confrerie71.
    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2416452
    Flobogo
    Modérateur
    Maître WordPress
    20193 contributions

    @confrerie71 :

    Désolée, j’avais oublié la pièce jointe en bas de mon message, je l’ai rajoutée.

    Bizarre ce blocage du fichier wp-config.php : vous n’y avez pas touché ?
    Vérifiez vos infos chez OVH, vous devriez trouver le nom d’utilisateur pour PhpMyAdmin (gestionnaire base de données), le nom de votre base de données, et peut-être votre mot de passe. Sinon, à voir avec OVH.

    Vous pourrez télécharger la dernière version de WP sur l’accueil du forum, ou bien sur cette page de téléchargement des différentes versions. Il faut renvoyer tous les fichiers (ou essayer avec juste ceux du dossier wp-includes), en les mettant à la place du dossier / fichiers actuels.

    * * * * * * * * * * * * *


    @himself
    : Votre proposition n’avance à rien. Si on veut accéder au tableau de bord, on va forcément passer par /wp-admin ou /wp-login.php …

    #2416453
    ferman
    Participant
    Maître WordPress
    7052 contributions

    Erreur lors de la connexion à la base de données

    Normalement ce message indique que les données de votre fichier wp-config, qui concernent la liaison du site à la base de données, sont incorrectes.

    Quand vous avez chargé les dossiers wordpress, auriez-vous modifié le fichier wp-config?

    Vérifiez que dans votre fichier wp-config (pas ovh-config), les données sont les mêmes que celles figurant dans votre espace client: nom d’utilisateur, nom de la base de données, adresse du serveur de cette base, mot de passe. Dans votre tableau de bord OVH faites  hébergement  > onglet base de données > en bas vous verrez ces données.  Le mot de passe (il s’agit de celui de la base de données, pas de celui pour se connecter au site) ne s’y trouve pas. Si vous le connaissez, regardez s’il est bien dans votre fichier wp-config, sinon il faudra corriger. Si vous ne le connaissez pas il faudra en recréer un (dans la ligne où figurent les données, cliquez les trois points à droite et dans la liste qui apparaît faites « changez votre mot de passe » (n’oubliez pas de le noter) et reportez-le dans votre wp-config. Il peut aussi y avoir un problème de préfixe des tables de la base de données. Si c’est le cas (j’espère que non), il faudra aller dans la base de données pour connaître ce préfixe. On verra ça si c’est nécessaire.

     

15 sujets de 16 à 30 (sur un total de 35)
  • Vous devez être connecté pour répondre à ce sujet.