500 internal server impromptue, sur site installé (Créer un compte)

  • Statut : non résolu
10 sujets de 1 à 10 (sur un total de 10)
  • Auteur
    Messages
  • #523298
    petitecirce
    Membre
    Chevalier WordPress
    168 contributions

    Bonjour,

    Ma configuration WP actuelle 3.5.1
    – Version de WordPress :
    – Version de PHP/MySQL : 5
    – Thème utilisé : (futur) graphène
    – Extensions en place :
    – Nom de l’hebergeur : ovh
    – Adresse du site : http://www.enfant-pratique.com

    Bonjour,

    Alors voilà, tout allait bien, utilisant un hébergement mutualisé chez ovh, j’avais réussi à installé un nouveau blog WordPress, j’ai fait l’enregistrement, aucun pb.

    Seulement, à un moment, en navigant dans le dashboard, PAF, l’écran a affiché “500 Internal Server Error”, alors que je n’avais touché à rien dans les dossiers via le FTP.

    Les autres sites sur le même hébergement mutualisé fonctionnent.

    J’ai tout désinstallé, réinstallé les fichiers, mais l’erreur est tjs là.

    Quelqu’un pourrait avoir la gentillesse de m’aider ? Merci par avance :

    #889322
    BertrandB21
    Participant
    Maître WordPress
    590 contributions

    .. une erreur 500 et généralement lié à deux problèmes possibles :
    une erreur dans une règle de .htaccess (ovh moyennement tolérant donc fréquent)
    une erreur php

    dans le cas de php j’ai eu sur un blog de test des comportements bizarres lié à des dysfonctionnement de CDN mais ça à l’air de s’être stabilisé. (et en ce moment des pb de routages ipv6)

    #889323
    petitecirce
    Membre
    Chevalier WordPress
    168 contributions

    Je ne pense pas que cela vienne de .htaccess car j’ai vérifié en le renommant “htaccess-test” (comme conseillé sur un tuto), et rien n’a changé.

    Comment faire pour savoir si c’est une erreur php ?

    #889324
    petitecirce
    Membre
    Chevalier WordPress
    168 contributions

    Et j’ajoute que j’ai rajouter ce code

    AddType x-mapp-php5 .php
    AddHandler x-mapp-php5 .php

    au fichier .htaccess

    L’erreur est tjs là…

    #889325
    BertrandB21
    Participant
    Maître WordPress
    590 contributions

    là il faudrait que quelqu’un hébergé chez ovh précise mais je crois que d’office on est déjà en php5 et donc les deux lignes addtype et addhandler sont inutiles.
    Avez vous regarder toute la chaine de .htaccess ? ceux ci sont consulté à partir de la racine de votre hébergement.

    Je ne suis pas sur du tout que ce soit une erreur php puisque l’appel direct http://www.enfant-pratique.com/wp-content/languages/fr_FR.po donne aussi une erreur 500 donc ça semble accuser une configuration apache. (donc les .htaccess en général c’est dans les règles de réécritures d’adresse que l’on se plante)

    #889326
    petitecirce
    Membre
    Chevalier WordPress
    168 contributions

    En fait le fichier .htaccess est directement au niveau du fichier racine. Je suis sur un hébergement mutualisé et pour les autres sites, cela fonctionne, alors que je ne vois pas de différence.

    Vraiment, je pateauge.

    #889327
    BertrandB21
    Participant
    Maître WordPress
    590 contributions

    alors un problème au niveau du fichier de configuration apache chez l’hébergeur ? poser leur la question ….

    #889328
    petitecirce
    Membre
    Chevalier WordPress
    168 contributions

    Je vais demander à ovh. Si j’ai la solution, je viendrai compléter ce sujet. %Erci en tout cas, de m’avoir répondue.

    #889329
    BertrandB21
    Participant
    Maître WordPress
    590 contributions

    en tout cas OVH a fait des travaux sur leur mutualisé ces derniers jours …. le forum est plein de râleries
    dans les manip il y a pu avoir un petit truc qui vous a créé ce pb justement.
    http://forum.ovh.com/showthread.php?t=88113

    en gros et en résumé ils ont revu leur distribution en cluster des mutualisés et leur load balancing … l’aventure a été assez douloureuse et notamment les mutu ont ramé pendant un certain temps mais je n’ai pas vu de personne signalant d’erreur 500.

    #889330
    petitecirce
    Membre
    Chevalier WordPress
    168 contributions

    C’est vraiment gentil de faire ce retour.

    Pour moi, qui n’est pas de connaissances particulières, c’est un peu du chinois, mais tes explications sont claires. Bon, pour mon mini-site, je vais farfouiller, il n’y a pas de raison que ça ne fonctionne pas !

    Merci encore

10 sujets de 1 à 10 (sur un total de 10)
  • Vous devez être connecté pour répondre à ce sujet.