[3.0.5] Problème d’url rewriting avec les permaliens et personnalisés (Créer un compte)

  • Statut : non résolu
Affichage de 1 message (sur 1 au total)
  • Auteur
    Messages
  • #492225
    Nakk
    Participant
    Initié WordPress
    41 contributions

    Bonjour à tous, je ne savais pas si je doit exposer mon problème ici ou sur le forum « Utilisation spécifique de WordPress », j’ai donc décidé de le mettre sur les deux. Si un modérateur passe par là, qu’il ait l’amabilité de le déplacer au bon endroit. Merci

    Ma configuration WP actuelle
    – Version de WordPress : 3.0.5
    – Version de PHP/MySQL : 5.2.5/5.0.45
    – Thème utilisé : D’origine
    – Extensions en place :
    – Nom de l’hebergeur :
    – Adresse du site :

    Problème(s) rencontré(s) :

    Voici mon problème, je suis en train de développer un plugin pour WordPress et je souhaiterai intégrer la réécriture des urls, à partir de ça, dans le fichier htaccess j’écris :

    RewriteEngine on

    RewriteRule ^([a-z]+)/([a-z]+)/([a-z-]+)/([a-z-]+)/([a-z0-9-]+)/annonce-([0-9]+)$ ?page_id=8&show_annonce=$6 [L]

    Donc en gros si je crée une balise avec comme href : http://monsite.com/aaaaa/bbbbb/ccccc/dddd/eeeee/annonce-34
    et que je clique dessus, la page qui s’affiche est celle qui s’affiche comme si j’étais directement allé sur http://monsite.com/?page_id=8&show_annonce=34

    Avec le paramètre par défaut de wordpress dans les permaliens : Valeur par défaut, la réécriture de l’url se fait correctement.

    Par contre, si je change et que je met comme paramètre permaliens : Date et titre, la page qui était la page avec un page_id=8 devient la page ‘annonce’ donc je décide de remplacer

    RewriteEngine on

    RewriteRule ^([a-z]+)/([a-z]+)/([a-z-]+)/([a-z-]+)/([a-z0-9-]+)/annonce-([0-9]+)$ ?page_id=8&show_annonce=$6 [L]

    par :

    RewriteEngine on

    RewriteRule ^([a-z]+)/([a-z]+)/([a-z-]+)/([a-z-]+)/([a-z0-9-]+)/annonce-([0-9]+)$ annonce/?show_annonce=$6 [L]

    Je vais donc sur : http://monsite.com/aaaaa/bbbbb/ccccc/dddd/eeeee/annonce-34 en espérant tomber sur
    http://monsite.com/annonce/?show_annonce=34 qui est une url qui fonctionne correctement.

    Sauf que ça ne marche pas et j’ai beau bidouiller de partout, rien n’y fait, la page ne s’affiche pas.

    J’espère ne pas avoir été trop long et que quelqu’un trouvera solution à mon problème.

    Cordialement.
    Nakk.

Affichage de 1 message (sur 1 au total)
  • Vous devez être connecté pour répondre à ce sujet.