Sortie de WordPress 2.6.1 en français !

Sortie de WordPress 2.6.1 en français !

Comme l’explique Ryan sur le blog de développement, avec la version 2.6.1, l’équipe de développement continue d’afficher sa marque de fabrique, c’est à dire sortir une version de maintenance peu de temps après une grosse mise à jour. En effet la version 2.6 possède quelques bugs et les développeurs ne voudraient pas que vous attendiez trop longtemps en leur compagnie…

Cependant si vous êtes content de la version 2.6, rien ne vous oblige de passer en 2.6.1, étant donné que cette dernière ne corrige aucun problème de sécurité. Pas d’inquiétude de ce coté donc.

La version 2.6.1 apporte quelques améliorations coté internationalisation, un meilleur rendu de la console d’administration pour les langues droite vers gauche, grâce à la contribution des communautés de WordPress (hébreux et perse). Un bug assez mystérieux concernant « gettext » sur certaines configurations PHP4 a été corrigé. Pour les utilisateurs du serveur HTTP de Microsoft IIS, un bug lié au permalien a été corrigé. Plusieurs corrections ont été réalisées dans le gestionnaire de média et les raccourcis de publication pour le navigateur IE6.

A noter, une amélioration sensible des performances dans la console administration, si vous disposez d’un grand nombre d’extensions.

Vous pouvez consulter la liste des bugs corrigés sur le trac de WordPress. La liste complète des fichiers modifiés est également disponible.

Vous pouvez télécharger WordPress 2.6.1, depuis notre page d’accueil, depuis fr.wordpress.org, et pour les utilisateurs de la version anglaise depuis le site de wordpress.org.

Je mets également à disposition un patch avec uniquement les fichiers modifiés et la traduction française à jour.

42 commentaires

  1. alain

    c’est une bonne nouvelle pour ceux qui ont connus beaucoup de bugs avec la version 2.6 !
    mais de mon côté je pense que je vais attendre la version 2.7 , car je n’ai pas de problèmes vraiment …

    d’ailleurs cette version est-elle déja en cours de développement ?

  2. Marchiavel

    Bonjour ^^

    Fidèle à WordPress depuis la version 2.3 (oui je suis arrivé récemment dans le monde WP), je n’ai jamais eu aucun problème d’upgrade… mais alors avec la 2.6, nomdidjou !

    Je vais sur le site WP francophone, télécharge la version intégralement francisée du pack, j’essaie une première fois de tout balancer correctement sur mon serveur, je suis (du verbe suivre, haha) les recommandations de sauvegardes, de fichiers à changer, comme d’hab etc. Et là pan ! Mon blog ne réagissait plus, même pas un petit accès au backend, que tchi.

    ** oui je raconte ma vie, ça peut durer longtemps, mais si ça peut en aider d’autres, allez hop **

    Je reviens donc à la version 2.5.1 avec toutes mes sauvegardes, et j’attends la 2.6.1 (ben tiens…) Rebelote, sur le site WP francophone je télécharge la nouvelle bestiole francisée, et PAREIL.
    Malgré toutes les recherches sur internet pour découvrir une quelconque solution, peine perdue.

    Et là, éclair de génie : j’ai téléchargé non pas le pack intégralement francisé en provenance du site WordPress-fr, mais le pack WP 2.6.1 original de WordPress.org (anglais, donc), en y ajoutant simplement les fichiers .mo et .po localisés en français dans un dossier languages.

    Et là ô joie, tout fonctionne. Conclusion, la version intégralement liftée et francisée du 2.6 et du 2.6.1 de wordpress-fr merdouille légèrement ! (ou j’avais un problème niveau serveur… ou pas).

    Sur ce, je file !
    Merci de m’avoir lu,
    Marc

  3. Classics

    Hello tout le monde. Super la nouvelle version de WordPress ! Par contre, plus ça va moins je peux utiliser de plugins.

    Subscribe to comments, google XML sitemap et maintenant MonsterID.

    Affreux ! Je vais repasser à la 2.5 je pense. :'(

  4. Benoît

    Marchiavel > La version francisée ne « merdouille » pas pour tout le monde donc je ne crois pas que le problème vienne de là… quelle version de PHP et MySQL tournent sur ton hébergeur ?

  5. Amaury auteur de l’article

    Marchiavel > Petite précision sur la méthode de traduction de WordPress.

    Automattic met à disposition un outil de packaging… Donc finalement, il n’y a que très peu de différence entre les 2 versions…

    Et finalement le ZIP officiel de WP.org et celui de WP-FR, qui n’est que celui fr.WP.org sont créé de la même facon.

    Bref, je mise plus sur un cas spécifique.

  6. Gtom

    Tout d’abord merci pour le boulot et la rapidité 🙂

    J’ai également eu un problème lors de l’installation (nouvelle install pas une mise à jour) avec la version 2.6.1 🙁

    J’ai dû également passer par la version US puis installation des fichiers de localisation, et là pas de soucis.

    Lors de l’install j’avais un message d’erreur « header location » sur /wp-includes/pluggable.php (ligne 770). Je n’ai plus le message d’erreur exact, désolé.

    La version 2.6 et la 2.6.1 (US) s’installe sans problème.

    Je confirme donc le problème rencontré par Marchiavel.

    A Plus

  7. Sven

    Salut

    J’ai aussi un problème chez Free.fr avec une install propre de la 2.6.1 pack Fr. J’ai un message d’erreur après l’étape où on rentre les infos du wp-config, message qui me dit que soit je n’ai pas rentré les bonnes informations, soit wordpress ne parvient pas à accéder à ma base de données…

    Ce problème ne survient pas avec une install de la version US. Il n’apparait pas non plus avec la version 2.6 oO (je précise que j’ai fait plusieurs install en même temps pour faire des tests)

    Enfin j’ai essayé de faire une mise à jour de la 2.6 Fr vers la 2.6.1 Fr et là tout fonctionne sans problème…

    Apparement chez Free, voilà la version de mysql utilisée : 5.0.51 . Php5 est utilisable au moyen d’un fichier htaccess contenant « php 1 » comme arguments

    Je ne sais pas si ça pourra vous aider à trouver l’origine du problème

  8. Ally

    Je trouve dommage qu’il y a autant de mises à jour car c’est dur de suivre le rythme ! Surtout quand on a un assez gros blog et qu’il faut croiser les doigts à chaque fois pour que tout se passe bien, on ne sait jamais quoi.

    En plus, suivent toujours les mises à jour des plugins ! J’espère franchement qu’il y aura moyen d’upgrader sans manip’ bientôt car c’est fatiguant.

    Malgré tout je sais que WP reste le meilleur CMS…

  9. Superleon

    Problème également avec la 1.6.1 Pack Fr.
    Pas de problème en revenche, en installant la 1.6.1 puis, en copiant les fichiers de la traduction française.

  10. initiateur

    Un petit commentaire en plus sur les problèmes d’install.

    J’avais fait le test avec le passage en 2.6.0 qui avait largement merdouillé pour un de mes blogs (simple upgrade car je les mets régulièrement a jour) du coup ca m’avait calmé, rebelotte avec la 2.6.1 pack fr, la j’ai plus accès a rien du tout.
    J’ai un XXL plan chez OVH (pour les stats)

  11. Amaury auteur de l’article

    Pour les installations à page blanche, ajouté ceci dans le fichier wp-config.php

    define(‘WP_DEBUG’, true);
    @ini_set(« display_errors », 1);

    Cela permet d’afficher les erreurs PHP, et donc de comprendre l’origine du problème.

    Et donc merci de me donner le message d’erreur 😉

  12. k|torz

    Bonjour,
    Vous allez dire que je pinaille mais lorsque je clique sur un tag ou une catégorie de mon blog sous wordpress 2.6.1, une série d’articles en relation est affichée mais le texte ‘Lire la suite’ reste en Anglais ‘More’ alors comment et où trouver le fichier pour traduire ce mot?
    Merci par avance et bonne journée.

  13. Amaury auteur de l’article

    Du coté du thème, et non du coté de la traduction… tu auras certainement plus de réponses sur le forum à ce sujet.

  14. Amaury auteur de l’article

    Gwaelia > Tu viens exactement de donner la méthode à NE JAMAIS FAIRE !!!

    Ne jamais hacker WordPress au risque de galérer lors de chaque mise à jour…

    k|torz > Du coté de ton thème à coup sur.

  15. Gwaelia

    Ah bon ? C’est vraiment une modification minime.
    En tout cas, ce n’est pas moi qui l’ai trouvé, mais bien sur le forum.

    En tout cas, merci pour l’avertissement 😉

  16. Alex

    +1 pour l’erreur à l’installation :
    seul le champ serveur est correct lors de la création de wp-config.php 🙁

  17. Amaury auteur de l’article

    Modification de l’encoding (UTF8 sans BOM) + restauration de lignes en anglais qui ne doivent pas être traduit 😉

  18. Bertrand

    Bonjour

    « Je mets également à disposition un patch avec uniquement les fichiers modifiés et la traduction française à jour. » Ce patch est-il ok ? J’ai essayé une mise à jour depuis WP FR 2.6, et j’obtiens message missing file compat.php … et impossible d’accéder à upgrade.php ..

    J’ai suivi les recommandations du readme, soit :
    Mise à jour depuis toutes les versions inférieures à WordPress 2.6.1 :

    1. Effacez vos anciens fichiers WordPress, sauf le dossier /wp-content/.
    2. Envoyez les nouveaux fichiers.
    3. Allez sur la page /wp-admin/upgrade.php avec votre navigateur internet.
    4. Vous vous attendiez à plus dur ? C’est tout !

    Quand je regarde dans l’archive, il n’y a en effet pas de fichier compat. L’archive bug avec Winzip, mais passe bien avec Winrar. Fichier corrompu ? Durant le download ou à la source ? Quelqu’un aurait une suggestion ? Une autre source pour simplement passer de WP 2.6 à WP 2.6.1.

    Merci d’avance.

Les commentaires sont fermés