Sortie de WordPress 2.5.1 en version française !

Sortie de WordPress 2.5.1 en version française !

La version 2.5.1 de WordPress est disponible. Cette dernière inclut quelques corrections de bugs, quelques améliorations de performances et la correction d’une très importante faille de sécurité.

Nous recommandons à tout le monde de mettre à jour leur blog le plus rapidement possible, particulièrement les personnes ayant autorisé l’inscription de nouveaux membres. Les détails de la vulnérabilité ne sont pas encore dévoilés publiquement mais ça ne serait trop tarder…

En addition à cette correction de sécurité, WordPress 2.5.1 contient plusieurs corrections de bugs. Si vous n’êtes intéressé que par les corrections de sécurité, vous pouvez récupérer que les fichiers suivants wp-includes/pluggable.php, wp-admin/includes/media.php, and wp-admin/media.php. Remplacer les fichiers existants avec ces nouvelles versions.

Si vous téléchargez la version complète, vous profiterez de la correction de 70 autres bugs. La version 2.5.1 corrige les bugs les plus ennuyeux et améliore les performances de la version 2.5. Voici un extrait:

  • Amélioration des performances du tableau de bord, page de rédaction et la page d’édition des commentaires
  • Meilleur performances pour les blogs avec de nombreuses catégories
  • Multiples corrections sur le gestionnaire de médias
  • Mise à jour de l’éditeur TinyMCE (version 3.0.7)
  • Correction de l’administration des Widgets
  • Quelques améliorations concernant l’ergonomie de l’administration
  • Corrections pour l’affichage sous IE

Ryan rappelle également de ne pas oublier de définir une phrase secrète pour sécuriser correctement votre installation. J’en ai parlé dans un précèdent article: Sécurisez une installation WordPress 2.5 provenant d’une mise à jour.

Pour le téléchargement, rendez vous sur fr.wordpress.org.

PS: Je ne fais pas de patch de mise à jour pour cette version, trop de fichiers ont été modifié, il est préférable de faire une mise à jour complète.

Remerciement à Steven Murdoch pour son report responsable de la faille de sécurité (CVE-2008-1930) et Alex Concha pour le report de la faille XSS.

66 commentaires

  1. Titimaxime

    Pas mal de fautes dans cette « traduction » pour la sortie de cette nouvelle version …
    « Nous recommande », « en addition », etc … C’est à se demander si ce n’est pas une traduction automatique …
    Cela dit, ça ne remet pas en cause votre travail et d’ailleurs, je m’en vais de ce pas mettre à jour mon wordpress !

  2. DaPo

    Maxamix: avant de faire quoi que ce soit, n’hésite pas à télécharger les anciens fichiers sur ton pc, et ensuite faire ce que Max11113 t’as dit.

    Comme ça, en cas de problèmes, tu as encore les anciens fichiers avec toi (:

  3. Maxamix

    Au pire je pourrais refaire une installation complète si problème, car je viens d’installer WordPress seulement, il n’y a aucun contenu.

    Voilà j’ai copié tous les fichiers mais on me propose toujours de faire la mise à jour dans l’admin…

  4. Alexandre

    Bonjour, moi j’ai toujours un soucis, j’ai fais comme d’habitude, et le message « WordPress 2.5.1 est disponible ! Pensez à faire une mise à jour. » continue d’apparaître. Pourquoi?

  5. Comme une image

    J’en profite pour poser une petite question : quelle(s) différence(s) y a-t-il entre la v.f. et la version originale, hormis le fichier int8 fr_FR.po/.mo et le fichier wp-config-sample.php ?

  6. Guilhem

    Ce qui devait arriver arriva.
    J’ai été trop confiant et trop rapide et j’ai fait ma mise à jour sans réfléchir, à l’arrache.
    Donc, je n’ai respecté aucune des règles (sauvegarde, arrêt des plug in, etc.).
    Malgré tout je ne constate aucun problème et ma mise à jour semble OK.
    Dois-je remercier le ciel et jurer de ne pas recommencer ou bien ai-je mis à mal le site et sa sécurité et dois-je tout reprendre à zéro ?
    De plus, j’ai modifié le fichier index.php comme indiqué pour la phrase de sécurité mais je n’ai pas uploadé le dossier content. Dois-je le faire vu que c’est là que se trouvent toutes mes modifs ?

    Merci de votre réponse.

  7. Amaury auteur de l’article

    Guilhem > On prend beaucoup de précision *au cas ou* je procède régulièrement comme toi… et je n’ai pas de problèmes…

    Il n’empêche, faire une mise a jour c’est toujours le bon moment pour faire une backup totale du blog…

  8. Dalipas

    Quelqu’un peut-il me rassurer ? Cette traduction est-elle partielle et est-ce normal que j’ai toujours une foule de choses en anglais comme :
    Tableau de bord :
    – Right Now Write a New Post Write a New Page
    – You have XX posts, XX pages, contained within 15 categories and XX tags.
    – You are using Yourblog 2.0 theme theme with 6 widgets. – Change Theme This is WordPress version 2.5.1.
    Page de rédaction de post :
    – Keep this post private
    – Publish immediately

    Ou est-ce moi qui ai mal fait la mise à jour ?
    Merci !

  9. mounik

    Moi j’ai un problème depuis la mise à jour.
    A chaque fois que je tente de me reconnecté dans l’admin c’est un peu comme de la roulette russe, soit ca passe soit (les trois quarts du temps) ca me met la page de connexion et ca ne reconnait pas mon mot de passe.

  10. Yazerty

    Guilhem > En fait ces « précisions » permettent aussi de dire aux gens qui ont foiré leur maj : « t’avais pas fait de sauvegarde ? ah …. dommage. » ;-P.
    Autant sauvegarder à l’occasion des maj, dans la lancée de la « maintenance ».
    Mais je fais comme toi à chaque fois, en sauvegardant l’intégralité des fichiers et de la bdd de temps en temps seulement, pour une question de sécurité basique.

    Dalipas > quelque chose a du foiré chez toi, pas de ça chez moi :).

  11. pat73

    Bonjour

    J’ai remplacé les 3 fichiers
    Je ne peux plus me logger en admin
    J’ai le msg suivant :

    Fatal error: Cannot redeclare media_upload_tabs() (previously declared in /home/www/tchub858690/www/wordpress/wp-includes/media.php:5) in /home/www/tchub858690/www/wordpress/wp-admin/includes/media.php on line 3

    ——- Que puis je faire ? ——

  12. Comme une image

    @ Amaury » Wahoo ! Ça fait tout de même quelques gros fichiers à modifier… Vous utilisez un outil spécifique pour reporter les éventuelles modification de la v.o. sans trop souffrir ?
    Je me pose la même question pour la traduction du fichier .po, j’ai fait un coup de diff entre la 2.5 et la 2.5.1 et j’ai énormément de « bruit » (c’est à dire de lignes qui changent mais sans importance) d’où une certaine difficulté pour repérer rapidement les différences. Comment faites vous ?

    @ Dalipas » je confirme la réponse de Yazerty !

    @ Guilhem » Pour les upgrades WP je préfère être prudent mais pour les upgrades de plugin, pardon, d’extensions, je prends moins de précautions : je teste en local (bah oui quand même) et zou, transfert direct par ftp à chaud.

    Encore que j’ai tendance à utiliser la méthode de mise à jour auto sans parfois tester en local mais j’ai régulièrement des soucis de time-out sur les extensions volumineuses et c’est pénible.

  13. Wolforg

    Salut, pour une maj de 2.3 faut il passer par un upgrade 2.3->2.5 puis 2.5->2.5.1 ou peut on passer directement à la 2.5.1 ?

  14. Amaury auteur de l’article

    Wolforg > Directement a la dernière version.

    Comme une image > On travaille avec SVN et les fichiers POT.

    La 2.5.1 m’a pris disons 40min, pour le package, la traduction des 25 chaines modifiées/ajoutées et la traduction de l’article initial.

  15. SolykZ

    Je viens de mettre à jour mon install’…j’ai droit à de multiples pages blanches. :/

    On fait comment pour revenir à la version précédente ? 🙂

  16. Un Monde Ailleurs

    Bonjour,

    Problème après la mise à jour sur mon blog : j’ai eu beau réactiver chacun de mes plugins, impossible d’uploader une quelconque image dans mes posts !… Plus aucun accès à l’upload.

    J’ai beau fouiller dans les forums, je ne vois pas où se trouve la solution. Sauriez-vous m’orienter s’il vous plait ?

    Merci…

  17. Un Monde Ailleurs

    Pour être plus précise, le Media Manager de la version 2.5.1 ne fonctionne pas quand je souhaite intégrer une image dans l’un de mes Posts. Si j’appelle une image (par exemple), un écran type calque Lightbox m’affiche « Etes-vous sur que vous voulez faire cela ? »

    Narquois, mais inefficace puisque je n’ai pas d’autre possibilité que de fermer ce calque pour revenir sous la gestion de mon Post.

  18. Jean

    J’ai le même problème que Dalipas. Je peux recommencer mais j’aurais aimé comprendre ce qui n’a pas marché.

  19. Jean

    J’ai compris : la version que j’avais téléchargée ne contenait pas de répertoire « languages ». Ce n’était pas la version fr !
    Mon site marchait donc avec l’ancien répertoire non mis à jour, d’où une traduction lacunaire !!

  20. Olivier

    Bonjours à tous,
    Je viens de faire la mise a jour en desactivant tous les plugins sauf « instant upgrade » avec lequel j’ai éffectué la dite mise a jour.
    Depuis, je ne peut plus accéder à mon interface d’administration car j’obtiens une « Error 403 – Forbidden
    L’accès au fichier requiert une autorisation »
    Le blog en lui même est pourtant accessible. que puis-je faire pour remédier à cela ?
    Précision : je suis chez 1&1.
    Merci par avance
    Cordialement
    Olivier

  21. Alain

    Salut la gang… J’ai supprimé tout mes fichiers de mon serveur et recommencer à neuf avec WP2.5.1… J’avais un problème de page qui disparaissait…. J’ai acheter un template Live Wire Edition parce que j’aimais le look et je l’ai placer… Or malgré que tout soit neuf mon blog continu a disparaitre et WP remet la page pas défault est-ce que quelqu’un a une idée à me soumettre, merci

  22. Alain

    Je recois également ce message d’erreur…Est-ce que quelqu’un sait pourquoi, merci

    Project-Id-Version: WordPress 2.5.1 Report-Msgid-Bugs-To: wp-polyglots@lists.automattic.com POT-Creation-Date: 2008-04-25 15:51 0000 PO-Revision-Date: 2008-04-26 12:53-0000 Last-Translator: Amaury Balmer Language-Team: French (France) MIME-Version: 1.0 Content-Type: text/plain; charset=UTF-8 Content-Transfer-Encoding: 8bit X-Rosetta-Version: 0.1 X-Poedit-Country: FRANCE X-Poedit-SourceCharset: utf-8 X-Poedit-KeywordsList: _e;_c;__ X-Poedit-Basepath: . Plural-Forms: nplurals=2; plural=n>1 X-Poedit-Language: French
    TEST

  23. Amaury

    Les commentaires sont la pour réagir sur l’article. Pas pour les demandes de support.

    Va sur le forum, tu auras plus de réponses !

    Alain > Problème sur le thème. Une chaine vide par exemple __( »)

  24. Samy

    @Dalipas : dans wp-content/languages, supprime les fr_FR.* et mets celui de la rubrique Téléchargements du site

  25. largowin

    Cette nouvelle version est archi lente pour moi. Autant la page de gestion que l’affichage de mon site.

    Je crois bien que je vais retourner à une version antérieure.

  26. MrT

    salut a tous ,
    j’ai essayer de mettre a jour en copiant tout le dossier 2.5.1 en excluant le WP-CONTENT comme indiqué , mais j’ai un ecran blanc lorsque je lance le blog ensuite. Heureusement j’avais sauvegardé .
    si quelqu’un sait d’ou le probleme peut venir ?
    merci bien :))

  27. INow

    Bonjour,

    J’ai mis à jour un peu rapidement mais pas plus que pour les versions précédentes, pourtant lorsque je lance wp-admin/upgrade.php et bien je reçois le message suivant : »Je ne trouve pas votre fichier wp-config.php. J’en ai besoin avant de lancer la mise à jour. » Bien sûr wp-config est en place.
    Merci de votre aide
    Philippe

  28. Nicolas

    Cette mise à jour ne sert à rien selon moi. A part si l’on souhaite pourrir son interface admin. Mal traduite, et en plus cette version est incompatible avec certains thèmes qui ne posaient aucun problème avec la version précédente.

  29. Nicolas

    L’usage, certainement pas celui de l’admin. Avec la bande wordpress dans la session admin qui se pose sur les menu et fenetre de selection c’est un peu nimp

Les commentaires sont fermés