Sortie de WordPress Mu 2.7.1 en français

Sortie de WordPress Mu 2.7.1 en français

WordPress Mu, la déclinaison multi-blogs de WordPress (utilisé par exemple sur WordPress.com) vient de passer en version 2.7.1. Comme le souligne Donncha, cette nouvelle version a mis du temps à aboutir, mais ça en valait la peine !

Cette version corrige un important bug de sécurité dans le mécanisme d’importation des données de WordPress (ce dernier permettait l’exécution de code PHP tiers), il est donc important de mettre à jour WordPress Mu vers cette version.

Les autres nouveautés et changements sont:

  • Les extensions installées dans le dossier “plugins” peuvent désormais être activées ou désactivées en un clic sur l’ensemble des blogs. Ainsi, nous disposons d’un excellent moyen d’utiliser les extensions incompatibles avec le chemin “mu-plugins”. Ce dernier reste toutefois très pratique pour les extensions indispensables à votre plateforme ne nécessitant pas de gérer l’activation et la désactivation.
  • La barre “admin” déroulante apparue dans WordPress Mu 2.7 a disparu. Pour la retrouver, il vous faudra utiliser une extension “WordPress Admin Bar“.
  • Ajout d’une page “Mes blogs” listant les blogs de l’utilisateur, il y a possibilité de paramétrer chaque blog. Cette fonctionnalité est vide pour le moment, mais elle peut être étendue via des extensions. Par exemple, choisir le nom affiché indépendamment sur chaque blog…
  • L’administrateur peut choisir un blog qui sera utilisé comme tableau de bord global pour les personnes n’ayant pas de blogs. Ainsi, les utilisateurs ne sont plus automatiquement ajoutés au blog principal, mais au blog spécifié. Le rôle des nouveaux utilisateurs peut également être personnalisé, mais s’il le rôle choisi n’est pas celui “Abonné”, l’utilisateur ne sera pas redirigé sur ce tableau de bord global.

Les extensions globales de WPmu, ca vous change la vie !
Les extensions globales de WPmu, ca vous change la vie !

Voilà les grandes modifications, il y a également des petites corrections incluant des erreurs lors de la mise à jour des blogs, WPmu ignore désormais le quota d’espace disque lors de l’importation d’un contenu depuis un système différent et bien d’autres bugs. Surveillez la timeline à l’avenir pour suivre les modifications.

Si vous utilisez WordPress Mu 2.7, vous pouvez mettre à jour depuis votre tableau de bord (même processus que la mise à jour de WordPress), cependant n’oubliez pas de faire une sauvegarde complète de vos fichiers et votre base de données.

De même, l’administrateur du site peut également mettre à jour en un clic les extensions installées depuis WordPress.org.

La version française est disponible depuis hier soir, elle corrige de nombreuses erreurs de traduction et est synchronisée avec la traduction de WordPress MU 2.7.1 US.

9 commentaires

  1. lubanoo

    Bonjour, je viens d’installer WPMU en anglais pour la première fois.

    Le pack que vous proposez semble très intéressant mais Je ne sais pas du tout comment l’installer.

    Auriez-vous un tutoriel?

  2. lubanoo

    La suite de mon installation (WPMU 2.7.1 avec votre pack FR)

    Lorsque je clique sur l’onglet ‘Extensions’ j’obtiens les erreurs suivantes:

    [b]en haut :
    [/b]

    Parse error: syntax error, unexpected T_STRING, expecting ‘,’ or ‘;’ in /mon-site/blogs-voyages/wp-admin/includes/mu.php(542) : runtime-created function on line 1

    Du plus, un peu plus bas j’obtiens:
    Warning: call_user_func_array() [function.call-user-func-array]: First argumented is expected to be a valid callback, ” was given in /mon-site/blogs-voyages/wp-includes/plugin.php on line 339

    Quelqu’un a-t-il obtenu le même type de problème?

    —> Est-ce que je dois passer à la version 2.6 en attendant que la version 2.7.1 soit plus stable?????
    —> Est-ce que je suis le seul à avoir eu cette erreur?

  3. Web612

    Idem pour la création de plusieurs sites sous wordpress j’ai testé Wpmu la nouvelle version mais j’ai la même erreur Parse error: syntax error, unexpected T_STRING, expecting ‘,’ or ‘;’ in /mon-site/blogs-voyages/wp-admin/includes/mu.php(542) : runtime-created function on line 1

    Impossible de trouver la cause et pas de réponse ?

Les commentaires sont fermés